Logo

Essential Server Maintenance

Incident Report for Devso

Incident affects the following services:
Crash Catch
Devso Blog
Devso Support Services
Test Track

Resolved: The maintenance window has been completed

Identified: We are performing essential server maintenance on Friday 11th August at 22:00 UTC. We do not expect any downtime during this period. We regularly perform server maintenance to ensure on going service reliability and perform necessary security patching.


Back to Status Overview