Logo

Upgrade of Test Track 21:00 UTC

Incident Report for Devso

Incident affects the following services:
Test Track

Resolved: The maintenance window has been completed

Identified: We will be performing an upgrade to Test Track on 31st May 2024 at 2100 UTC. This upgrade includes the ability to reorder test steps and changes to the subscription offerings. When registering you can choose between monthly and annual subscriptions and choose to pay in GBP or USD. The currency of the subscription can only be changed before your subscription activiation (e.g. after payment details are provided). If you want to change from monthly to annual billing, then please raise a support ticket via https:/support.devso.io. The free plan will no longer be available, and any plans that are on the free option, will auto switched to the Indie plan with a 30 day trial (up from the normal 14 days).


Back to Status Overview